# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[^A-Z]*[A-Z][^A-Z]*//gm;t' <<< "They won. Elles gagnèrent.
They won. Ils ont gagné.
They won. Elles ont gagné.
Tom came. Tom est venu.
Tom died. Tom est mort.
Tom knew. Tom savait.
Tom left. Tom est parti.
Tom left. Tom partit.
Tom lied. Tom a menti.
Tom lies. Tom ment.
Tom lost. Tom a perdu.
Tom paid. Tom a payé."