# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[^A-Z]*[A-Z][^A-Z]*"
test_str = ("They won. Elles gagnèrent.\n"
"They won. Ils ont gagné.\n"
"They won. Elles ont gagné.\n"
"Tom came. Tom est venu.\n"
"Tom died. Tom est mort.\n"
"Tom knew. Tom savait.\n"
"Tom left. Tom est parti.\n"
"Tom left. Tom partit.\n"
"Tom lied. Tom a menti.\n"
"Tom lies. Tom ment.\n"
"Tom lost. Tom a perdu.\n"
"Tom paid. Tom a payé.")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.