#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(?:[^<>()[\].,;:\s@"]+(\.[^<>()[\].,;:\s@"]+)*|"[^\n"]+")@(?:[^<>()[\].,;:\s@"]+\.)+[^<>()[\]\.,;:\s@"]{2,63}$"
Local $sString = "abcde.fghi@gmail.com" & @CRLF & _
"" & @CRLF & _
"nombre-apellido@do-mi-nio.info" & @CRLF & _
"germán@bla.com" & @CRLF & _
"yo@mi-compañía.com" & @CRLF & _
"estação@brasil.com.br" & @CRLF & _
"no@esunmail" & @CRLF & _
"**@as" & @CRLF & _
"juan@{{192.168.1.52}}" & @CRLF & _
"*****@mail.xx" & @CRLF & _
"#($^%#$@^(#$^.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")