use strict;
my $str = 'abcde.fghi@gmail.com
nombre-apellido@do-mi-nio.info
germán@bla.com
yo@mi-compañía.com
estação@brasil.com.br
no@esunmail
**@as
juan@{{192.168.1.52}}
*****@mail.xx
#($^%#$@^(#$^.com';
my $regex = qr/^(?:[^<>()[\].,;:\s@"]+(\.[^<>()[\].,;:\s@"]+)*|"[^\n"]+")@(?:[^<>()[\].,;:\s@"]+\.)+[^<>()[\]\.,;:\s@"]{2,63}$/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}