package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^(?:[^<>()[\].,;:\s@"]+(\.[^<>()[\].,;:\s@"]+)*|"[^\n"]+")@(?:[^<>()[\].,;:\s@"]+\.)+[^<>()[\]\.,;:\s@"]{2,63}$`)
var str = `abcde.fghi@gmail.com
nombre-apellido@do-mi-nio.info
germán@bla.com
yo@mi-compañía.com
estação@brasil.com.br
no@esunmail
**@as
juan@{{192.168.1.52}}
*****@mail.xx
#($^%#$@^(#$^.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}