using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[^<>()[\].,;:\s@""]+(\.[^<>()[\].,;:\s@""]+)*|""[^\n""]+"")@(?:[^<>()[\].,;:\s@""]+\.)+[^<>()[\]\.,;:\s@""]{2,63}$";
string input = @"abcde.fghi@gmail.com
nombre-apellido@do-mi-nio.info
germán@bla.com
yo@mi-compañía.com
estação@brasil.com.br
no@esunmail
**@as
juan@{{192.168.1.52}}
*****@mail.xx
#($^%#$@^(#$^.com";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}