import re
regex = re.compile(r"^(?:[^<>()[\].,;:\s@\"]+(\.[^<>()[\].,;:\s@\"]+)*|\"[^\n\"]+\")@(?:[^<>()[\].,;:\s@\"]+\.)+[^<>()[\]\.,;:\s@\"]{2,63}$", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("abcde.fghi@gmail.com\n\n"
"nombre-apellido@do-mi-nio.info\n"
"germán@bla.com\n"
"yo@mi-compañía.com\n"
"estação@brasil.com.br\n"
"no@esunmail\n"
"**@as\n"
"juan@{{192.168.1.52}}\n"
"*****@mail.xx\n"
"#($^%#$@^(#$^.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")