import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[a-zA-Z]=\")([\\w\\W]*)(?:<ins>|<del>)([\\w\\W\\s]*)(?:<\\/ins>|<\\/del>)([\\w\\W]*)(?=\">)";
final String string = "<div class=\"class1<ins>class2</ins>\" style=\";display:block;\">Some Text</div>\n";
final String subst = "$1 $2 $3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}