re = /(?<=[a-zA-Z]=")([\w\W]*)(?:<ins>|<del>)([\w\W\s]*)(?:<\/ins>|<\/del>)([\w\W]*)(?=">)/
str = '<div class="class1<ins>class2</ins>" style=";display:block;">Some Text</div>
'
subst = '$1 $2 $3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result