import Foundation
let pattern = #"(?<=[a-zA-Z]=")([\w\W]*)(?:<ins>|<del>)([\w\W\s]*)(?:<\/ins>|<\/del>)([\w\W]*)(?=">)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<div class="class1<ins>class2</ins>" style=";display:block;">Some Text</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 $2 $3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)