$re = '/(?<=[a-zA-Z]=")([\w\W]*)(?:<ins>|<del>)([\w\W\s]*)(?:<\/ins>|<\/del>)([\w\W]*)(?=">)/';
$str = '<div class="class1<ins>class2</ins>" style=";display:block;">Some Text</div>
';
$subst = "$1 $2 $3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;