#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\G(?!\A)|Stop)\D+\K\d+(?:\.\d+)?"
Local $sString = " HELLO 1 Stop #$**& 5.02‼️ 16.1 " & @CRLF & _
" regex" & @CRLF & _
"" & @CRLF & _
" 5 ,#2.3222"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")