using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!\A)|Stop)\D+\K\d+(?:\.\d+)?";
string input = @" HELLO 1 Stop #$**& 5.02‼️ 16.1
regex
5 ,#2.3222";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}