import re
regex = re.compile(r"(?:\G(?!\A)|Stop)\D+\K\d+(?:\.\d+)?", flags=re.MULTILINE)
test_str = (" HELLO 1 Stop #$**& 5.02‼️ 16.1 \n"
" regex\n\n"
" 5 ,#2.3222")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")