re = /(?:\G(?!\A)|Stop)\D+\K\d+(?:\.\d+)?/m
str = ' HELLO 1 Stop #$**& 5.02‼️ 16.1
regex
5 ,#2.3222'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end