const regex = new RegExp('(?:\\G(?!\\A)|Stop)\\D+\\K\\d+(?:\\.\\d+)?', 'gm')
const str = ` HELLO 1 Stop #\$**& 5.02‼️ 16.1
regex
5 ,#2.3222`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}