$re = '~(?:\G(?!\A)|Stop)\D+\K\d+(?:\.\d+)?~m';
$str = ' HELLO 1 Stop #$**& 5.02‼️ 16.1
regex
5 ,#2.3222';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);