using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[a-zA-Z]*([0-9]{11}000[0-9]{2})[a-zA-Z]*\b";
string input = @"1234567890100012
abc1234567890100012abc
999912345678901000129999";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}