// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b[a-zA-Z]*([0-9]{11}000[0-9]{2})[a-zA-Z]*\b").unwrap();
let string = "1234567890100012
abc1234567890100012abc
999912345678901000129999";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}