package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[a-zA-Z]*([0-9]{11}000[0-9]{2})[a-zA-Z]*\b`)
var str = `1234567890100012
abc1234567890100012abc
999912345678901000129999`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}