const regex = /\b[a-zA-Z]*([0-9]{11}000[0-9]{2})[a-zA-Z]*\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[a-zA-Z]*([0-9]{11}000[0-9]{2})[a-zA-Z]*\\b', 'gm')
const str = `1234567890100012
abc1234567890100012abc
999912345678901000129999`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}