import re
regex = re.compile(r"\b[a-zA-Z]*([0-9]{11}000[0-9]{2})[a-zA-Z]*\b", flags=re.MULTILINE)
test_str = ("1234567890100012\n"
"abc1234567890100012abc\n"
"999912345678901000129999")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")