re = /\b[a-zA-Z]*([0-9]{11}000[0-9]{2})[a-zA-Z]*\b/m
str = '1234567890100012
abc1234567890100012abc
999912345678901000129999'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end