#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(3[01]|[12][0-9]|0[1-9])$"
Local $sString = "01" & @CRLF & _
"02" & @CRLF & _
"03" & @CRLF & _
"09" & @CRLF & _
"10" & @CRLF & _
"11" & @CRLF & _
"15" & @CRLF & _
"19" & @CRLF & _
"20" & @CRLF & _
"25" & @CRLF & _
"30" & @CRLF & _
"31" & @CRLF & _
"32" & @CRLF & _
"33" & @CRLF & _
"100"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")