import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(3[01]|[12][0-9]|0[1-9])$";
final String string = "01\n"
+ "02\n"
+ "03\n"
+ "09\n"
+ "10\n"
+ "11\n"
+ "15\n"
+ "19\n"
+ "20\n"
+ "25\n"
+ "30\n"
+ "31\n"
+ "32\n"
+ "33\n"
+ "100";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}