// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(3[01]|[12][0-9]|0[1-9])$").unwrap();
let string = "01
02
03
09
10
11
15
19
20
25
30
31
32
33
100";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}