re = /^(3[01]|[12][0-9]|0[1-9])$/m
str = '01
02
03
09
10
11
15
19
20
25
30
31
32
33
100'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end