package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(3[01]|[12][0-9]|0[1-9])$`)
var str = `01
02
03
09
10
11
15
19
20
25
30
31
32
33
100`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}