#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<!-- Facebook Comments Plugin for WordPress(?:.|[\r\n])+?<\/comments>"
Local $sString = "<!-- Facebook Comments Plugin for WordPress -->" & @CRLF & _
"<comments>" & @CRLF & _
"Inner tag content" & @CRLF & _
"</comments>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")