import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<!-- Facebook Comments Plugin for WordPress(?:.|[\\r\\n])+?<\\/comments>";
final String string = "<!-- Facebook Comments Plugin for WordPress -->\n"
+ "<comments>\n"
+ "Inner tag content\n"
+ "</comments>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}