const regex = /<!-- Facebook Comments Plugin for WordPress(?:.|[\r\n])+?<\/comments>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<!-- Facebook Comments Plugin for WordPress(?:.|[\\r\\n])+?<\\\/comments>', 'gm')
const str = `<!-- Facebook Comments Plugin for WordPress -->
<comments>
Inner tag content
</comments>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}