$re = '/<!-- Facebook Comments Plugin for WordPress(?:.|[\r\n])+?<\/comments>/m';
$str = '<!-- Facebook Comments Plugin for WordPress -->
<comments>
Inner tag content
</comments>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);