re = /<!-- Facebook Comments Plugin for WordPress(?:.|[\r\n])+?<\/comments>/m
str = '<!-- Facebook Comments Plugin for WordPress -->
<comments>
Inner tag content
</comments>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end