using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<!-- Facebook Comments Plugin for WordPress(?:.|[\r\n])+?<\/comments>";
string input = @"<!-- Facebook Comments Plugin for WordPress -->
<comments>
Inner tag content
</comments>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}