package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^0-9a-z -]+`)
var str = `шфшешег123asdsafsafре-реtjrt`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}