$re = '/[^0-9a-z -]+/';
$str = 'шфшешег123asdsafsafре-реtjrt';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;