import Foundation
let pattern = #"[^0-9a-z -]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"шфшешег123asdsafsafре-реtjrt"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)