# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\|("[^,]+")\|/$1/gm;t' <<< "(STR,0:30) + |\"Outdoor\"| + |\"Chair Mat\",\"Commercial Floor Mat\",\"Door Mat\"| + [Post Type] + (STR,0:30)"