const regex = /\|("[^,]+")\|/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\|("[^,]+")\\|', 'gm')
const str = `(STR,0:30) + |"Outdoor"| + |"Chair Mat","Commercial Floor Mat","Door Mat"| + [Post Type] + (STR,0:30)`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);