re = /\|("[^,]+")\|/m
str = '(STR,0:30) + |"Outdoor"| + |"Chair Mat","Commercial Floor Mat","Door Mat"| + [Post Type] + (STR,0:30)'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result