import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\|(\"[^,]+\")\\|";
final String string = "(STR,0:30) + |\"Outdoor\"| + |\"Chair Mat\",\"Commercial Floor Mat\",\"Door Mat\"| + [Post Type] + (STR,0:30)";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}