using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\|(""[^,]+"")\|";
string substitution = @"$1";
string input = @"(STR,0:30) + |""Outdoor""| + |""Chair Mat"",""Commercial Floor Mat"",""Door Mat""| + [Post Type] + (STR,0:30)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}