package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\|("[^,]+")\|`)
var str = `(STR,0:30) + |"Outdoor"| + |"Chair Mat","Commercial Floor Mat","Door Mat"| + [Post Type] + (STR,0:30)`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}