#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\[\[file:(.*?(?:\.jpg|\.gif|\.bmp|\.png))(?:\||]).*"
Local $sString = "[[File:EDI.png|thumb|304x304px|none]]" & @CRLF & _
"[[File:RMS Home screen.png|thumb|none]]" & @CRLF & _
"[[File:ClipCapIt-170110-133309.PNG]]" & @CRLF & _
"[[file:send-rec.jpg|thumb|none]]" & @CRLF & _
"[[file:send-rec.12412.2.123.jpg|thumb|none]]" & @CRLF & _
"[[file:send-rec.12412.2.123.jpg|thumb|none]]" & @CRLF & _
"[[file:send-rec.12412.2.123.not-jpg|thumb|none]]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")