# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[\[file:(.*?(?:\.jpg|\.gif|\.bmp|\.png))(?:\||]).*"
test_str = ("[[File:EDI.png|thumb|304x304px|none]]\n"
"[[File:RMS Home screen.png|thumb|none]]\n"
"[[File:ClipCapIt-170110-133309.PNG]]\n"
"[[file:send-rec.jpg|thumb|none]]\n"
"[[file:send-rec.12412.2.123.jpg|thumb|none]]\n"
"[[file:send-rec.12412.2.123.jpg|thumb|none]]\n"
"[[file:send-rec.12412.2.123.not-jpg|thumb|none]]")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.