// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\[\[file:(.*?(?:\.jpg|\.gif|\.bmp|\.png))(?:\||]).*").unwrap();
let string = "[[File:EDI.png|thumb|304x304px|none]]
[[File:RMS Home screen.png|thumb|none]]
[[File:ClipCapIt-170110-133309.PNG]]
[[file:send-rec.jpg|thumb|none]]
[[file:send-rec.12412.2.123.jpg|thumb|none]]
[[file:send-rec.12412.2.123.jpg|thumb|none]]
[[file:send-rec.12412.2.123.not-jpg|thumb|none]]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}