use strict;
my $str = '[[File:EDI.png|thumb|304x304px|none]]
[[File:RMS Home screen.png|thumb|none]]
[[File:ClipCapIt-170110-133309.PNG]]
[[file:send-rec.jpg|thumb|none]]
[[file:send-rec.12412.2.123.jpg|thumb|none]]
[[file:send-rec.12412.2.123.jpg|thumb|none]]
[[file:send-rec.12412.2.123.not-jpg|thumb|none]]';
my $regex = qr/\[\[file:(.*?(?:\.jpg|\.gif|\.bmp|\.png))(?:\||]).*/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}