import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\\[file:(.*?(?:\\.jpg|\\.gif|\\.bmp|\\.png))(?:\\||]).*";
final String string = "[[File:EDI.png|thumb|304x304px|none]]\n"
+ "[[File:RMS Home screen.png|thumb|none]]\n"
+ "[[File:ClipCapIt-170110-133309.PNG]]\n"
+ "[[file:send-rec.jpg|thumb|none]]\n"
+ "[[file:send-rec.12412.2.123.jpg|thumb|none]]\n"
+ "[[file:send-rec.12412.2.123.jpg|thumb|none]]\n"
+ "[[file:send-rec.12412.2.123.not-jpg|thumb|none]]";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}