const regex = new RegExp('\\b\\'s\\b', 'gm')
const str = `Python's Programming: is very easy to learn in str.`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);