$re = '/\b\'s\b/m';
$str = 'Python\'s Programming: is very easy to learn in str.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;